HI Everyone
Is there a way you can see how lookup table examed each value and make the call whether it is match or not. something like you read value A then go into lookup table check line one not match, check line two not match, check line three matched, return value B.
I have this time based lookup table looks like below
user1 gain_access 24/11/17 11:00
user2 gain_access 24/11/17 12:00
user1 gain_access 23/11/17 10:00
user1 gain_access 24/11/17 15:00
user2 gain_access 24/11/17 11:20
My data is standard Sysmon log
I run following queue
index=windowslog Image=*\\userinit.exe ParentImage=*\\winlogon.exe
| eval AccountName=mvindex(User,1)
| stats dc(_time) as eventNums by AccountName _time
| rex field=AccountName "(?<Account_Name>\w*\.\w*)"
| lookup swipe FullUserName AS Account_Name OUTPUT Action AS hereitis
| table Account_Name _time hereitis
| sort - _time
and the lookup result shows non of the record is match in the lookup table. but I know there are time and Account_Name is matching.
I test the lookup table by remove the timebased setting and only let it match the name and it works fine get following result
user1 24/11/17 11:00 gain_access
gain_access
gain_access
user2 24/11/17 12:00 gain_access
gain_access
that make me think it is the time format failed the lookup but I cant tell the different between the lookup table and the actual search time field.
Any advice please?
Regards
Sam
... View more