Hi
I have data that looks like below, as you can see some parts have blanks.
Date | Time | UserName |iD | Context | Command
20161209|17:28:55.238|MUREXFO | 1 |LOGIN |SPBActUserLogin
20161209|17:29:02.456|MUREXFO | 1 | |Login
20161209|17:29:28.555|MUREXFO | 2 |Report Selection |
20161209|17:29:32.344|MUREXFO | 3 |Report Selection NAME |&Open
20161209|17:29:33.404|MUREXFO | 4 |Creation INFO |&Open
20161209|17:29:35.966|MUREXFO | 5 |ADT_OBJDSP |
20161209|17:29:38.907|MUREXFO | 6 |Scenario details |Open
I am able to work whit these with a normal Query, however when i use Data Models i cant.
Below Query works as i can replace blank with NULL and that is fine - I get 10 entries and it displays NULL
index=mlc_log_drop host="mxtiming_qc3" source="/net/dell425srv/dell425srv/apps/SPLUNK_FILES/MXTIMING_QC3/Resources/logs/MXTIMING/mxtiming_small.log" | fillnull value=NULL |dedup Context |table Context
However i cant seem to do this with DataModels, I only get 9 entries as NULL is not displayed. I am not sure how to add this at the DataModel level.
| tstats count(MXTIMING.CPU) AS count FROM datamodel=MXTIMING where source="/net/dell425srv/dell425srv/apps/SPLUNK_FILES/MXTIMING_QC3/Resources/logs/MXTIMING/mxtiming_small.log" groupby MXTIMING.Context
We can see in the image i get 9 results in the tstats and 10 in the normal with NULL
... View more