Yes, the mistake i was making was running evals before i had pulled all me data back. The final query was this one.
| tstats summariesonly=true avg(MXTIMING.Elapsed) AS average, count(MXTIMING.Elapsed) AS count, stdev(MXTIMING.Elapsed) AS stdev, median(MXTIMING.Elapsed) AS median, exactperc95(MXTIMING.Elapsed) AS perc95, exactperc99.5(MXTIMING.Elapsed) AS perc99.5, min(MXTIMING.Elapsed) AS min, max(MXTIMING.Elapsed) AS max,earliest(_time) as start, latest(_time) as stop FROM datamodel=MXTIMING_TEST WHERE
host=TALANX_PostGoLive
AND MXTIMING.Elapsed > 5
AND MXTIMING.source_path = **
AND MXTIMING.UserName2=*
AND MXTIMING.NPID=***
AND MXTIMING.MXTIMING_TYPE_DM=STANDARD
AND MXTIMING.Context+Command = **#*
AND MXTIMING.Context+Command = *#**
AND MXTIMING.Time = *
GROUPBY MXTIMING.Context+Command MXTIMING.NPID MXTIMING.Time | rename MXTIMING.Context+Command as Context+Command |rename MXTIMING.NPID as NPID
| join NPID [| tstats summariesonly=true count(SERVICE.NPID) AS count2 FROM datamodel=SERVICE WHERE ( host=TALANX_PostGoLive)
AND SERVICE.NICKNAME = mx
GROUPBY SERVICE.NICKNAME SERVICE.NPID | rename SERVICE.NPID AS NPID ] | join Context+Command type=left [inputlookup TEST_MXTIMING.csv | rename Context_Command AS Context+Command ] | search | where average > Threshold OR isnull('Threshold') | fillnull Tags | eval Tags=if(Tags=0,"NO_TAG",Tags) | search Tags = *
| stats avg(average) as average count(count) as count stdev(average) as stdev median(median) as median exactperc95(perc95) AS perc95, exactperc99.5(perc99.5) AS perc99.5, min(min) AS min, max(max) AS max,earliest(_time) as start, latest(_time) as stop by Context+Command Tags | sort - average
... View more