I have a DHCP search that I filter based on a lookup:
index=DHCP_IDX sourcetype="infoblox:dhcp" signature IN (DHCPACK, DHCPREQUEST)
| eval unified_mac=if(isnull(src_mac),dest_mac,src_mac)
| eval unified_ip=if(isnull(src_ip),dest,src_ip)
| eval unified_host=if(isnull(src_nt_host),if(isnull(dest_nt_host),"Unknown", dest_nt_host),src_nt_host)
| search
[| inputlookup dhcp_lookup
| eval unified_mac=lookup_mac
| eval unified_ip=cidr_ip
| eval unified_host=lookup_hostname
| fields unified_mac, unified_ip, unified_host]
| table _time action signature src_ip src_nt_host src_mac dest dest_nt_host dest_mac
| sort -_time
Inside this lookup are 4 columns: cidr_ip, lookup_mac, lookup_hostname, and Notes
Right now, the outer search is being filtered by the first 3 fields. However, I need to find a way to add in the Notes column to the outer search for the results.
An example row for the dhcp_lookup would be:
cidr_ip | lookup_mac | lookup_hostname | Notes
0.0.0.0/0 | aa:22:33:44:11:55 | * | Bad Device by MAC
I need to be able to use Wildcards in the MAC and Hostname columns, but I need to somehow add the Notes column as a field into the outer search while still filtering using the lookup.
Any ideas?
... View more