Splunk Search

Splunk searching Syntax

keyu921
Explorer

Resolved

Labels (2)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @keyu921,

sorry, what's the question?

does your search run or doesn't give you the waiting for results?

Could you share what you would have and what yu really have with this search?

viewing you search I see that you could optimize it but it doesn't seem to be wrong

index=windows host=* EventCode=19  NOT (TaskCategory="Windows Update Agent" OR
Message="*Update for Microsoft Defender Antivirus*" OR Message="*Security Intelligence Update*")
| table _time host EventCode Message

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: The Agentic SOC: Trust Before Autonomy

AI is fundamentally changing security operations, but true progress requires more than just automation—it ...

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...