Splunk Search

Splunk searching Syntax

keyu921
Explorer

Resolved

Labels (2)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @keyu921,

sorry, what's the question?

does your search run or doesn't give you the waiting for results?

Could you share what you would have and what yu really have with this search?

viewing you search I see that you could optimize it but it doesn't seem to be wrong

index=windows host=* EventCode=19  NOT (TaskCategory="Windows Update Agent" OR
Message="*Update for Microsoft Defender Antivirus*" OR Message="*Security Intelligence Update*")
| table _time host EventCode Message

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...