Splunk Search

Need help with SPL for windows logins

Roy_9
Motivator

Hello,

I have the below SPL where I am looking to fetch the user accounts that have not logged in for 30 days or more but I am not seeing any results, Can someone please help me with this query if everything is good.

index=windows sourcetype=* EventCode=4624 
| stats latest(_time) as lastLogon by Account_Name
| eval days_since_last_logon = round((now() - lastLogon) / 86400, 0)
| where days_since_last_logon > 30
| table Account_Name, days_since_last_logon


Thanks in advance

Labels (3)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

It looks good to me.  Perhaps there are no users who haven't logged in for 30 days.  Try changing 30 to 1 as a test.

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

It looks good to me.  Perhaps there are no users who haven't logged in for 30 days.  Try changing 30 to 1 as a test.

---
If this reply helps you, Karma would be appreciated.

Roy_9
Motivator

Yup @richgalloway ,  it worked now.

I have set it to 1 and tested.


Thanks

0 Karma

richgalloway
SplunkTrust
SplunkTrust

If your problem is resolved, then please click the "Accept as Solution" button to help future readers.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...