Splunk Search

How can we use predict command with tstats?

att35
Builder

Hi,

I have the following search that works against a datamodel to plot a timechart. How can I use predict command with this output?

 

 

| tstats summariesonly=true count FROM datamodel="modelname.dataset" where dataset.field="xyz"  by dataset.field, _time span=1h prestats=t  | timechart  span=1h count  by dataset.field usenull=f useother=f

 

 

If I try to do following,

 

 

| predict dataset.field

 

 

 search failed with this error.
command="predict", Unknown field: dataset.field
 
What is the correct way to do this?
 
UPDATE:
Turns out, | predict "xyz" works, but this would mean it is working just for that one value of the field.
 
Thanks
Labels (2)
Tags (3)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

timechart is using dataset.field for values of field names in the y axis and doesn't exist any more - try predict count

0 Karma

att35
Builder

@ITWhisperer 

Same result.

command="predict", Unknown field: count

 

With timechart everything works fine, it plots using dataset.field or even with "field" after rename. But predict doesn't seem to be taking any option as input. Only way predict works here is if I use direct value of the field.

| predict value

 

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Have you tried renaming the field?

| tstats summariesonly=true count FROM datamodel="modelname.dataset" where dataset.field="xyz"  by dataset.field, _time span=1h prestats=t  
| rename dataset.field as field
| timechart  span=1h count by field usenull=f useother=f
| predict field
---
If this reply helps you, Karma would be appreciated.
0 Karma

att35
Builder

Hi @richgalloway ,

Tried that but now it just gives same error message for field.

command="predict", Unknown field: field
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...