Splunk Search

Help to convert date using strftime

Marco_Develops
Path Finder

Currently I have a field holding a Julian date. I am trying to convert it using strftime but i'm having issues.

 

Date = 2022.091

Current query:

 

 

index = * | eval ConvertedDate = strftime(DATE,"%Y.%j")| table ConvertedDate

 

 

 

Ideally I would like to get an output like 04/03/2022

 

Thank you,

Marco

Labels (2)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

The strftime function converts an epoch timestamp (integer) into a human-readable string.  Use the strptime function to convert a datetime string into epoch form.

 

index = * 
| eval ConvertedDate = strftime(strptime(DATE,"%Y.%j"), "%m/%d/%Y")
| table ConvertedDate

 

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

The strftime function converts an epoch timestamp (integer) into a human-readable string.  Use the strptime function to convert a datetime string into epoch form.

 

index = * 
| eval ConvertedDate = strftime(strptime(DATE,"%Y.%j"), "%m/%d/%Y")
| table ConvertedDate

 

 

---
If this reply helps you, Karma would be appreciated.

Marco_Develops
Path Finder

@richgalloway This worked. Thank you for your time and explanation . 

-Marco

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...