Splunk SOAR

Errno 110 App ElasticSearch Configuration

johnteo
Explorer

I have been trying to troubleshoot this error for the Elasicsearch application. However, with or without credentials I have run into the same error output.

App 'Elasticsearch' started successfully (id: 157241367048) on asset: 'elastic'(id: 13)
Loaded action execution configuration
Connecting to 192.168.30150:9200...
Querying cluster health to check connectivity
Using authentication
Connection failed. Error string 'HTTPConnectionPool(host='192.168.30.150',port=9200): Max retries exceeded with url:/_cluster/health (Caused by NewConnectionError(':Failed to establish a new connection: [Errno 110] Connection timed out'))'. Test Connectivity Failed. No action executions found.

The above cycle then continues to repeat itself with the same output when undergoing Testing Connectivity.

Labels (1)
Tags (1)
0 Karma
1 Solution

cblumer_splunk
Splunk Employee
Splunk Employee

a timeout error like this typically indicates a network connectivity issue preventing the connection (firewall/proxy) - I would recommend running some connection tests from the phantom host to your ES instance. netcat/telnet/traceroute are a good place to start troubleshooting.

View solution in original post

cblumer_splunk
Splunk Employee
Splunk Employee

a timeout error like this typically indicates a network connectivity issue preventing the connection (firewall/proxy) - I would recommend running some connection tests from the phantom host to your ES instance. netcat/telnet/traceroute are a good place to start troubleshooting.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...