Splunk Enterprise Security

Network data statics dashboard

Splunk_rocks
Path Finder

Hello,

I have request to collect all network data based allowed denyed and dropped traffic info from various network feeds.
Unfortunately my network data model is not set only 15 days worth of data so i have to run manual searches to collect data so any
help will be much appreciated .
I have tried with below one but not showing all data and any help will be much appreciated

| tstats summariesonly=t allow_old_summaries=f count
 FROM datamodel=Network_Traffic.All_Traffic 
 WHERE index=* BY sourcetype All_Traffic.action _time span=1h 
 | rename All_Traffic.* AS * 
 | stats count As total_connections count(eval(action=="allowed")) AS allowed count(eval(action=="blocked" OR action=="dropped")) AS blocked BY _time, sourcetype 
 | eval pct_blocked = 100 * blocked / total_connections
0 Karma

DalJeanis
Legend

Certain things are a little unclear.

1) how much data do you want?
2) how much data is on the underlying indexes?
3) how much data is the data model set to retain?
4) have you verified that the data model is fully up to date and there are no skipped searches?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...