Splunk Dev

Why do we have to use "index=*" in our development environment, but not in production?

ajs
Engager

We have export and import some data from our production to development environment with same fields. But we found that "index=*" must be added to query in development environment. Could we know what we should set to make it the same as production? Thanks.

0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...