Splunk Dev

Why do we have to use "index=*" in our development environment, but not in production?

ajs
Engager

We have export and import some data from our production to development environment with same fields. But we found that "index=*" must be added to query in development environment. Could we know what we should set to make it the same as production? Thanks.

0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

Verify the user roles are the same in PROD and DEV. It sounds like the DEV role does not have the same set of default indexes as the PROD role. Go to Settings->Access controls->Roles and select the appropriate role. Check the settings under "Indexes searched by default".

---
If this reply helps you, Karma would be appreciated.
Get Updates on the Splunk Community!

Tech Talk | Elevating Digital Service Excellence: The Synergy of Splunk RUM & APM

Elevating Digital Service Excellence: The Synergy of Real User Monitoring and Application Performance ...

Adoption of RUM and APM at Splunk

    Unleash the power of Splunk Observability   Watch Now In this can't miss Tech Talk! The Splunk Growth ...

March Community Office Hours Security Series Uncovered!

Hello Splunk Community! In March, Splunk Community Office Hours spotlighted our fabulous Splunk Threat ...