Security

Unable to access online documentation

Engager

I have trialled v4.3 and it has now switched to the free version. My problem, however, existed prior to the license change. This is not a connectivity issue, as the browser can open a window to splunk.com with no problem. The test workstation is running Windows XP SP3.

When clicking the 'Learn more' link on an entry in the License Manager screen, after 10 seconds the page simply displays "Unable to access online documentation". On examining the source for the page, it appears that I am missing an entire folder tree, viz. [webroot]/en-GB, as in:

        <script type="text/javascript" src="/en-GB/config?autoload=1"></script>             
        <script type="text/javascript" src="/en-GB/static/@115073/js/common.min.js"></script>                 

Having said that, the installing MSI doesn't contain an entry in the Directory table to create that folder. Perhaps one of the myriad Custom Actions does that....

SplunkTrust
SplunkTrust

I receive "Unable to access online documentation. Please ensure docsCheckerBaseURL in web.conf is correct." with pop-up blocker turned off, no blocking. Do you know what the configuration for docsCheckerBaseURL in web.conf should look like? https://localhost:8000/en-US/help?location=learnmore.datamodel.about

0 Karma

Splunk Employee
Splunk Employee

Do you have other extensions running? Does your console show net::ERR_BLOCKED_BY_CLIENT?

0 Karma

SplunkTrust
SplunkTrust

I have other extensions, but none are blocking. I get "help?location=manager.apps.local:142 GET http://docs.splunk.com/Documentation/pro/7.1.2/manager.apps.local/prod/default?locale=en-US&product=... net::ERR_ABORTED 404 (Not Found)"

0 Karma

Splunk Employee
Splunk Employee

Correction. I can't reproduce the issue here. Apologies for the confusion. I was not looking at 7.1.2.

In 7.1.2 (for real), in a fresh local installation, the help links work for me.

http://localhost:8000/en-US/help?location=manager.apps.local

correctly resolves to

https://docs.splunk.com/Documentation/Splunk/7.1.2/Admin/Managingappobjects.

0 Karma

SplunkTrust
SplunkTrust

Thank you for working on this Chris.
What is your Web.conf CheckerBaseURL set to?

0 Karma

SplunkTrust
SplunkTrust

The solution was I changed the docsCheckerBaseURL URL to https://quickdraw.splunk.com/help and I'm able to reach the documentation now. Thank you for your help working on this.

Splunk Employee
Splunk Employee

There are a few possible causes for the help links to fail.

  • Sometimes it is a firewall or network issue.
  • You might have a browser extension running that interferes with the call (AdBlock Plus is one likely culprit, or based on the comments below, Privacy Badger). Your browser developer tools console will show net::ERR_BLOCKED_BY_CLIENT if this is the case.
  • Occasionally there is a transient problem that causes help links to fail, but that should resolve if you clear your cache and refresh the page.

Motivator

I have EFF Privacy Badger on my (Chrome) browser. I was getting this same thing. After reading this I disabled it for my Splunkweb site, and now the Splunk Documentation and Tutorial buttons work correctly.

Motivator

When I get this message and I do <ctrl><shift>I a pane opens on the right which shows this (Chrome, by the way):

Failed to load resource: net::ERR_BLOCKED_BY_CLIENT quickdraw.splunk.com/help/pro/6.5.2/splunkcore.homepage.docs/prod/default?locale=en-US&product=enterprise:1

I added quickdraw.splunk.com to the Disabled Sites list in Privacy Badger, and tried it again, and got the exact same thing.

I tried this on a co-workers browser and it worked fine, and then I noticed that quickdraw.splunk.com had redirected to docs.splunk.com, so I added that into the Disabled Sites list and it still does not work.

What did you do in Privacy Badger to allow this to work properly?

0 Karma

Motivator

Okay, I figured it out. I had to click on Privacy Badger icon after the error occurred, then click on Disable Privacy Badger for this site.

Why manually editing the exception list did not fix it I do not know. But it works now. I reported this to IETF

0 Karma

Contributor

EFF Privacy Badger was the culprit for me too.

0 Karma

Same problem here: Splunk 6.4.0 on Windows 8.1,
http://localhost:8000/en-US/help?location=learnmore.search.transforming

0 Karma

Explorer

I am having the same problem on two separate servers: Brand new fresh install of Splunk for Windows. The URL in question:

http://splunkserver:8000/en-US/help?license=pro&locale=en-US&versionNumber=4.3.2&installType=trial&l...

0 Karma

Engager

Update 20120308_0942
I have uninstalled and reinstalled Splunk, this time opting directly for the free license. I am still prompted, after 10 seconds, "Unable to access the online documentation".

Interestingly, the free license is set to expire 6 days AGO!

0 Karma

Splunk Employee
Splunk Employee

can you provide the URL for that help link? (hover over, right click, copy link)

0 Karma