Knowledge Management

List index from a datamodel

kuriakose
Explorer

Hi,

 

can someone one help me with an SPL so that I can list the indexes of a datamodel.

datamodel name - authentication.malware

 

Appreciate your help in advance.

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

It's not clear what you're looking for.  To find which indexes are used by a datamodel:

| tstats count from datamodel=<datamodelname> by index

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

kuriakose
Explorer

You are awesome. Thanks a lot.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

It's not clear what you're looking for.  To find which indexes are used by a datamodel:

| tstats count from datamodel=<datamodelname> by index

 

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...