Getting Data In

Timezone

Khuzair81
Path Finder

How to convert the below the time field from GMT to EST. 

time=Jun 7, 2021 10:24:33 AM GMT

i tried below

| eval t=strftime(strptime(time, "%m %d, %y %H:%M:%S %Z"), "%H:%M:%S")

I'm not getting the result

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

The strptime format string doesn't match the sample time string.  Try this

| eval t=strftime(strptime(time, "%b %d, %y %H:%M:%S %p %Z"), "%H:%M:%S")

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

Khuzair81
Path Finder

@richgalloway i want to get the data only from yesterday is there anyway to write it in Query

Can i use  | where Date=-1d@d

0 Karma

richgalloway
SplunkTrust
SplunkTrust

This should be a new posting, but, yes, you can do that, however not using where.  To search only yesterday, use the earliest and latest options to the search command.

index=foo earliest=-1d@d latest=@d

 

---
If this reply helps you, Karma would be appreciated.
0 Karma

richgalloway
SplunkTrust
SplunkTrust

The strptime format string doesn't match the sample time string.  Try this

| eval t=strftime(strptime(time, "%b %d, %y %H:%M:%S %p %Z"), "%H:%M:%S")

 

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...