Getting Data In

Export Host list

aaronwerley
New Member

Looking to see how I would export a list of all hosts which have reported to splunk all time. I can generate the info with * | top hosts limit 10000, however it takes forever to complete... there has to be a faster search as I am not concerned with the total events per host, just looking for a list of hosts.

Tags (1)
0 Karma
1 Solution

bojanz
Communicator

You should be able to see the lists of hosts with the metadata command:

| metadata type=hosts index=*

View solution in original post

bwili
Explorer

You can get a nice ordered list with this:

| metadata type=hosts index=* | stats count by host

bojanz
Communicator

You should be able to see the lists of hosts with the metadata command:

| metadata type=hosts index=*
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...