Dashboards & Visualizations

Hide HTML with simple checkbox

mclane1
Path Finder

Hello

 

  <row>
    <panel>
      <title>Manage alerts</title>
      <input type="checkbox" token="detail_input_token">
        <label></label>
        <choice value="hide">Hide detail</choice>
        <initialValue>hide</initialValue>
      </input>
      <html>debug detail_input_token:$detail_input_token$</html>
      <html rejects="$detail_input_token$">
        <body>
        <p> 
          <A HREF="/manager/myapp/data/lookup-table-files?ns=myapp&amp;pwnr=-&amp;search=mySearch&amp;count=100" target="_blank">
            Manage <B>lookup mySearch</B>  (csv files).
          </A>
        </p>
        </body>
      </html>
    </panel>
  </row>

 

 

It works in splunk 6.4.2
We migrate on splunk 8.2 and it doesn't work now.
I do many change without success. 
Does somebody have an idea ?

Thanks in advance.

Labels (2)
0 Karma
1 Solution

mclane1
Path Finder

I find solution.

When we have already many inputs you must specify the searchWhenChanged and set to "true"

  <row>
    <panel>
      <title>Manage alerts</title>
      <input type="checkbox" token="detail_input_token" searchWhenChanged="true">
        <label></label>
        <choice value="hide">Hide detail</choice>
        <initialValue>hide</initialValue>
      </input>
      <html>debug detail_input_token:$detail_input_token$</html>
      <html rejects="$detail_input_token$">
        <body>
        <p> 
          <A HREF="/manager/myapp/data/lookup-table-files?ns=myapp&amp;pwnr=-&amp;search=mySearch&amp;count=100" target="_blank">
            Manage <B>lookup mySearch</B>  (csv files).
          </A>
        </p>
        </body>
      </html>
    </panel>
  </row>

 Now it works

View solution in original post

kamlesh_vaghela
SplunkTrust
SplunkTrust

cool @mclane1 

Please accept your solution and close this question 

KV

🙂

 

 

0 Karma

mclane1
Path Finder

Is it ok ?

0 Karma

kamlesh_vaghela
SplunkTrust
SplunkTrust

@mclane1 

The checkbox behaviour  working for me on Splunk Version: 8.2.2.1.

It that anything specific which not working?

 

Screenshot 2021-10-04 at 11.50.50 AM.png

 

Screenshot 2021-10-04 at 11.51.03 AM.png

 

 Thanks
KV
▄︻̷̿┻̿═━一   😉

If any of my reply helps you to solve the problem Or gain knowledge, an upvote would be appreciated.

0 Karma

mclane1
Path Finder

I find solution.

When we have already many inputs you must specify the searchWhenChanged and set to "true"

  <row>
    <panel>
      <title>Manage alerts</title>
      <input type="checkbox" token="detail_input_token" searchWhenChanged="true">
        <label></label>
        <choice value="hide">Hide detail</choice>
        <initialValue>hide</initialValue>
      </input>
      <html>debug detail_input_token:$detail_input_token$</html>
      <html rejects="$detail_input_token$">
        <body>
        <p> 
          <A HREF="/manager/myapp/data/lookup-table-files?ns=myapp&amp;pwnr=-&amp;search=mySearch&amp;count=100" target="_blank">
            Manage <B>lookup mySearch</B>  (csv files).
          </A>
        </p>
        </body>
      </html>
    </panel>
  </row>

 Now it works

View solution in original post

.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!