All Apps and Add-ons

hyper v add on

New Member

where do i copy this huyperv add on , i have installed universal forwarderon hyperv hosts and installed vitualization apps on splunk management .copied hyper v add on to splunk/etc/apps folder . I restarted the splunk universal forwader but when i use splunk search(splunk>apps>search)hyperv hosts are listed but nothing is showing on splunk apps for server virtualization tab.

0 Karma

Splunk Employee
Splunk Employee

greetings from the future. I believe that downloading the supported version and following its documentation will cure all ills of this type.

0 Karma

Engager

Here's what I did to make it "work"... not sure how well it's working yet, but here goes anyway...

  1. Install, configure and confirm Splunk Universal Forwarder is working on Hyper-V host (2008 R2)
  2. Download the tgz file from splunk-base.
  3. Copied tgz file to Hyper-V host (it was called TA-HyperV08-Server.tar.gz)
  4. From the Hyper-V host, ran Powershell as administrator, then ran this command> set-executionpolicy RemoteSigned
  5. Extracted tgz file. You'll see that there's a folder inside of the tgz file which is also named "TA-HyperV08-Server". The deepest folder with this name is what you want - it has folders inside of it called bin, default, local, and metadata
  6. Copied that folder called TA-HyperV08-Server to $splunk_home\etc\apps folder [for me in Windows 2008 R2, this was c:\program files\splunkuniversalforwarder\etc\apps\ ]
  7. Restarted Splunk Universal Forwarder
  8. Went to Splunk > Apps > Splunk App for Server Virtualization
  9. Saw my Hyper-V host name listed.

Engager

Hi,
I have the same problem. I have set my PowerShell execution policy to RemotedSigned and even to Unrestricted but still not working. I get information from the scripts and the Generic Event Logs but nothing from the Perfmon.conf. Therefore in my indexer I have information related to the hierarchy, alarms and events but no performance at all.

0 Karma

New Member

managed to fix this. I added the perfmon to the inputs.conf file in the local directory and added the servervirt index to all the lines (might not be necessary), all working since.

0 Karma

New Member

I have the same issue, no cpu,mem,disk performance information on the hosts or VM.

0 Karma

Splunk Employee
Splunk Employee

via the developer comment on http://docs.splunk.com/Documentation/ServerVirt/latest/DeployServerVirt/Installtheaddons

"the Hyper-V addons go on the Hyper-V hosts along with the Splunk Universal Forwarder. The addon scripts use PowerShell, so make sure the PowerShell execution policy is set correctly."

New Member

yes , i have restart the forwader on all hyperv hosts,

My Scenario is like this ,

Installed splunk apps for server virtualization on managemnt server

Insatalled universal forwader and copied hyper v addon on to c:/programfiles/splunkuniversalforwader/etc/apps folder all hyper v hosts ,

Restart the splunk universal forwader

when i use splunk search(splunk>apps>search)hyperv hosts are listed but nothing is showing on splunk apps for server virtualization tab.

0 Karma

Explorer

I have the same issue. How did you get it working?

0 Karma

SplunkTrust
SplunkTrust

Did you restart the forwarder after adding the apps folder?

0 Karma