All Apps and Add-ons

Using rex to split raw field

Janani_Krish
Path Finder

I have raw field in the below format.

{"device":"device1","date":"2020-09-16T05:17:04.197Z","file_path":"CSIDL_PROFILE\\appdata","file_hash":"1bcdefgh12469"}

I wanted the content of file_path like "CSIDL_PROFILE\\appdata"[inclusing quotes]. I tried something like below,

sourcetype="file"|rex "{"device":"*","date":"*","file_path":(?<file>.*)"|table _raw,file

I am not good at rex queries. Please suggest me some ideas to take the values of file_path including quotes.

Labels (1)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

This looks like json so spath may be an easier option

 

| spath file_path
| eval file_path="\""+file_path+"\""

 

Second line adds the quotes back in 

If you still want to use rex, try:

| rex "file_path\"\:(?<file_path>\"[^\"]+\")"

View solution in original post

thambisetty
SplunkTrust
SplunkTrust

simple, value will be extracted to new field called "file_path"

 

| rex "file_path\":(?<file_path>[^\,]+)"

 

————————————
If this helps, give a like below.

gcusello
SplunkTrust
SplunkTrust

Hi @Janani_Krish,

if you want to include also quotas, please, try this regex:

| rex "\"file_path\":(?<file_path>[^,]*),"

that you can test at https://regex101.com/r/IBotDY/1

Ciao.

Giuseppe

ITWhisperer
SplunkTrust
SplunkTrust

This looks like json so spath may be an easier option

 

| spath file_path
| eval file_path="\""+file_path+"\""

 

Second line adds the quotes back in 

If you still want to use rex, try:

| rex "file_path\"\:(?<file_path>\"[^\"]+\")"
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...