Alerting

Windows alert..

Vishal2
Explorer

By using below Query it's working for to find out the only one windows server but can you please post  by using lookup containing all the hosts to Monitor.

 

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 

| stats count by host 

| where count > 1

Labels (1)
0 Karma
1 Solution

venkatasri
SplunkTrust
SplunkTrust

@Vishal2  You are expecting something like this? host_list is the lookup name having host field having pre-populated windows hosts in your org?

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 [| inputlookup host_list | return 1000 host ]
| stats count by host 
| where count > 1

 

 

View solution in original post

venkatasri
SplunkTrust
SplunkTrust

@Vishal2  You are expecting something like this? host_list is the lookup name having host field having pre-populated windows hosts in your org?

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 [| inputlookup host_list | return 1000 host ]
| stats count by host 
| where count > 1

 

 

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Catalog Is Now Generally Available on Splunk Cloud Platform

A Unified View of Your Data  Security logs, application events, business data, and historical telemetry often ...

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner

Your Path to AgenticOps: AI Experiences for Every Splunk Practitioner   Watch on demand us for a demo-driven ...