Alerting

Windows alert..

Vishal2
Explorer

By using below Query it's working for to find out the only one windows server but can you please post  by using lookup containing all the hosts to Monitor.

 

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 

| stats count by host 

| where count > 1

Labels (1)
0 Karma
1 Solution

venkatasri
SplunkTrust
SplunkTrust

@Vishal2  You are expecting something like this? host_list is the lookup name having host field having pre-populated windows hosts in your org?

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 [| inputlookup host_list | return 1000 host ]
| stats count by host 
| where count > 1

 

 

View solution in original post

venkatasri
SplunkTrust
SplunkTrust

@Vishal2  You are expecting something like this? host_list is the lookup name having host field having pre-populated windows hosts in your org?

index=<your_index> source=WinEventLog* EventCode=41 OR EventCode=1074 OR EventCode=6006 OR EventCode=6008 [| inputlookup host_list | return 1000 host ]
| stats count by host 
| where count > 1

 

 

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI &#43; Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...

Splunk Technical Support Is Moving to Cisco Support Tools

Introduction Splunk technical support is transitioning to Cisco’s support environment. This change brings ...