Finally got it working...
first, create a lookup table first with the IPs that I want to cross reference:
index=nessus severity=critical | stats count by dest_ip | table dest_ip | outputlookup crit_vuln_hosts.csv
second, cross reference that table against all of my indexes except for the nessus one:
| inputlookup crit_vuln_hosts.csv | fields dest_ip | search NOT [ search index!=nessus | dedup dest_ip | fields dest_ip ]
... View more