I was able to achieve what I needed, by using this thread's answer as a reference. The sanitized search I created is below. Thank you all for your assistance.
sourcetype="antivirus" [ search sourcetype="antivirus" EventCode=600 | eval earliest=_time | eval latest=_time+60 | fields earliest,latest | format "(" "(" "" ")" "OR" ")" ] | eval status = if(EventCode="500",1,0) | stats sum(status) as statusCount values(virus) by Computer,file_name | where statusCount = 0
This search finds an event indicating malware was found but not cleaned. It then uses that timestamp as a reference and look ahead 60 seconds. If it does not find an event indicating that the malware was cleaned, it will trigger. The search runs -6m@m to -1m@m every 5 minutes.
... View more