Splunk Search

splunk

vinod0313
Explorer

I have two queries and i want to append those two queries and i need new column for separation
for ex:
i got below result from query 1

total     avg       max
10          15         16


and i got below result from query 2
total     avg       max
51          50        19


i want to append both queries and I want result like below

Name       total   avg    max
first           10         15       16
second     51         50        19

 

 

 

So I want new column with "Name"

could anyone please help on this??

Labels (1)
0 Karma

saravanan90
Contributor

append command may help..  Query1 | eval Name="first"  | append [|search query2| eval Name="second"] 

index=_internal | stats avg(kbps) as avg, max(kbps) as max,sum(kbps) as total | eval Name="_internal"| append [search index=_audit| stats avg(kbps) as avg, max(kbps) as max,sum(kbps) as total | eval Name="_audit"] | table Name avg max total

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...