Splunk Search

searchFieldsToDisplay order

timmalos
Communicator

I cant manage to find a way to order my select as I want.
I got this script:

        <module name="SearchSelectLister" layoutPanel="viewHeader" autoRun="True">
            <param name="searchFieldsToDisplay">
                <list>
                    <param name="value">Name</param>
                    <param name="label">Name</param>
                </list>
                <list>
                    <param name="value">Id</param>
                    <param name="label">Id</param>
                </list>
            </param>

My problem is that the values in the pulldown are shown in this order : Name1, Id1, Name2, Id2, Name3, Id3 etc... I would the following order : Name1, Name2, Name3,...Name N, Id1, Id2,...IdN

Is it possible?

0 Karma
1 Solution

timmalos
Communicator

I got around my problem and did a search that returns both Name and Id in a same field (Sorted like i wanted) so that I can have only one list in my searchFieldsToDisplay module.

index="infra_vmware" $host$ earliest=-2h latest=now|dedup Id| eval Id=Id+","+Name)|table Id| makemv delim="," Id|mvexpand Id|sort Id

Don't know if it's the best solution, but works 🙂

View solution in original post

0 Karma

timmalos
Communicator

I got around my problem and did a search that returns both Name and Id in a same field (Sorted like i wanted) so that I can have only one list in my searchFieldsToDisplay module.

index="infra_vmware" $host$ earliest=-2h latest=now|dedup Id| eval Id=Id+","+Name)|table Id| makemv delim="," Id|mvexpand Id|sort Id

Don't know if it's the best solution, but works 🙂

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...