Splunk Search

problem using lookup output field

changux
Builder

Hi all.
I have an automatic file lookup configured to output some fields and works very well (using the sourcetype):

sourcetype=datavalue *

The field from the automatic lookup is GOAL1. This field only has a integer numeric value.

Next, i tried to run:

sourcetype=datavalue ORDER=pending | stats count AS s | eval FINAL = (s * 100)/GOAL1

But the result of FINAL is not shown. If i remove the division per GOAL1, is fine (s * 100). First, i reckoned that maybe GOAL1 has some problem, but with

sourcetype=datavalue | table GOAL1

i can see the integer as unique value.

Any idea?

0 Karma

mhpark
Path Finder

you would like to check if your GOAL1 is really an numeric, not a string.
try

| eval GOAL1 = tonumber(GOAL1)

or something and do the math again

gcusello
Legend

how is your lookup done?
I tried with a lookup not automatic, but called in the search, and it's ok!
Bye?
Giuseppe

0 Karma
Get Updates on the Splunk Community!

BSides Splunk 2022 - The Call for Papers is now Open!

TLDR; Main Site: https://bsidessplunk.com CFP Site: https://bsidessplunk.com/cfp CFP Opens: December 15th, ...

Sending Metrics to Splunk Enterprise With the OpenTelemetry Collector

This blog post is part of an ongoing series on OpenTelemetry. The OpenTelemetry project is the second largest ...

What's New in Splunk Cloud Platform 9.0.2208?!

Howdy!  We are happy to share the newest updates in Splunk Cloud Platform 9.0.2208! Analysts can benefit ...