Splunk Search

Yes / No Column if EventCode Found in Lookup

aferone
Builder

I have a lookup table with certain Windows Event Codes.  I am searching our Windows index for all Windows Event Codes.  I would like a count of all Windows Event Codes, per Event Code, and a column that says whether that Event Code is in my lookup table.  This is what I am attempting partly with what I found on Answers, but it isn't working:

 

 

| inputlookup MyWinEvCodes 
| fields EventCode 
| append 
    [ search index=winsevlog 
    | stats count as Count by EventCode
        ] 
| eval Found = if(Count > 1,"Yes","No") 
| stats count by EventCode, Found 
| sort + count

 

Thank you in advance!

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

Try this query.

index=winsevlog 
| stats count as Count by EventCode
| fields - count
| lookup MyWinEvCodes EventCode OUTPUT EventCode
| eval Found = if(isnotnull(EventCode),"Yes","No") 
| table EventCode, Found 
---
If this reply helps you, Karma would be appreciated.

View solution in original post

0 Karma

aferone
Builder

Thanks!

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try this query.

index=winsevlog 
| stats count as Count by EventCode
| fields - count
| lookup MyWinEvCodes EventCode OUTPUT EventCode
| eval Found = if(isnotnull(EventCode),"Yes","No") 
| table EventCode, Found 
---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

From Data to Insight: Announcing the Winners of the Splunk Dashboard Contest

Hi Splunkers, First off, thank you to everyone who participated in our very first From Data to Insight: The ...

Splunk Developers: Construct Your Future at the .conf26 Builder Bar

Calling all Splunk architects, platform admins, and app developers: the site is open, and the blueprints are ...

Quick connection discovery mode for forwarders

When a Splunk forwarder loses connectivity to its indexers, it does not always reconnect immediately. In many ...