Splunk Search

What does connected do in transaction command

mohammadsharukh
Path Finder

I am working to create a use case to detect account created and deleted within short period of time

Could you please give a simple example how connected true/false will affect results of transaction command.

I already referred previous answer but didnt understand the explanation.

Addionally also explain what is the affect of connected=true/false in the below query and also what is the best practice.

sourcetype=wineventlog (EventCode=4726 OR EventCode=4720)  | transaction user maxspan=240m startswith="EventCode=4720" endswith="EventCode=4726" connected=false| table Time, dest, EventCode, user, src_user, Account_Domain

@Ledion_Bitincka 

 @richgalloway 

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @mohammadsharukh,

if I correctly remember, there's a sample of a shourt living account in the Splunk Security Essential App, that I hint.

Anyway, don't use the transaction command because it's very slow, please try this search:

sourcetype=wineventlog (EventCode=4726 OR EventCode=4720)  
| stats 
   earliest(eval(EventCode=4720)) AS earliest
   latest(eval(EventCode=4726)) AS latest
   values(dest) AS dest
   values(src_user) AS src_user
   values(Account_Domain) AS Account_Domain
   BY user 
| eval 
   diff=latest-earliest,
   creation_time=strftime(earliest,"%Y-%m-%d %H:%M:%S"),
   deletion_time=strftime(latest,"%Y-%m-%d %H:%M:%S")
| where diff<240*60
| table 
   creation_time 
   deletion_time 
   dest 
   EventCode 
   user 
   src_user 
   Account_Domain

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOK it to Me: Top 3 Benefits of Using Splunk Operator on Kubernetes that’ll Make ...

    Thursday, July 9, 2026  |  11:00AM–12:00PM PDT Duration: 1 hour (includes Q&A) Managing can feel like a ...

Upgrade Prep for 10.4, Network Observability Deep Dives, and More from Splunk Lantern

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Splunk Developer Day announcements: AI agents, MCP tools, Forecasting, and Custom ...

Splunk Developer Day was packed with product and platform updates for developers building in the AI ...