Splunk Search

Splunklib API retrieve inputlookup

Tim00
Explorer

Hi all,

have been using the splunklib package in Python to connect to the Splunk API for some time now, and it works fine. As sample search I use is provided below:

searchquery = """search index=wineventlog EventCode=4688 earliest=-4h | fields user, ETC, ETC, ETC
| table user, ETC, ETC, ETC"""
resolveQuery = SplunkQuery(host, port, username, password)
df = resolveQuery.splunk_fetch(searchquery)

The search return a pandas dataframe (in Python) containing the required information.

When I try to retrieve an inputlookup however, the search doesn't return any information, only an empty dataframe.  Below is an example of a searchquery I use to try and retrieve an inputlookup:

searchquery = """search | inputlookup infomation.csv"""

Any help would be highly appreciated: how can I retrieve inputlookups using the Splunklib package in Python?

0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

The inputlookup command is supposed to be the first command in a query.  Try this:

searchquery = """| inputlookup infomation.csv"""

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

Tim00
Explorer

Thanks for your help

0 Karma

richgalloway
SplunkTrust
SplunkTrust

The inputlookup command is supposed to be the first command in a query.  Try this:

searchquery = """| inputlookup infomation.csv"""

 

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Defend at Machine Speed: Your Guide to Security Sessions at .conf26

Splunk .conf26   With threats moving at machine speed and attack surfaces expanding across hybrid ...

Where Innovation Takes Flight: The Splunk4Aviation Flight Sim Lands at .conf26

If you hear someone at .conf26 shouting "gear down, GEAR DOWN" across the show floor, you have found us.  The ...

Turn Cisco Telemetry Into Action with Cisco Data Fabric, powered by the Splunk ...

The surge in machine data is already hitting enterprise budgets, and the agentic era will only intensify it. ...