Splunk Search

Splunk searching Syntax

keyu921
Explorer

Resolved

Labels (2)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @keyu921,

sorry, what's the question?

does your search run or doesn't give you the waiting for results?

Could you share what you would have and what yu really have with this search?

viewing you search I see that you could optimize it but it doesn't seem to be wrong

index=windows host=* EventCode=19  NOT (TaskCategory="Windows Update Agent" OR
Message="*Update for Microsoft Defender Antivirus*" OR Message="*Security Intelligence Update*")
| table _time host EventCode Message

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...