Splunk Search

Splunk 8.0.1 : How to change show_source CSS about long lines

mpasini
Engager

Hello,

After upgrading to Splunk 8 from Splunk 6, it seems that the "show_source" view  ( used in "Event actions" -> "Show source" ) isn't wrapping the long lines as it used to do before.

We've isolated the new setting in jsx code in:

/opt/splunk/share/splunk/search_mrsparkle/exposed/js/views/show_source/index.jsx

 

    tableRow: {
        border: 0,
        margin: 0,
        padding: 0,
        whiteSpace: 'nowrap',
    },​

Before the setting was set to 'white-space: pre-wrap' as we can see in our backups of search_mrsparkle from splunk6.

Is there any way for us to go the same behavior as before so that the long lines in "Show source" are wrapped ?

 

Labels (1)
0 Karma
1 Solution

mpasini
Engager

Actually,  I found that the "wrapping" option was lost until the version 8.0.4 when the "Wrap Results" button was added:

mpasini_0-1628521423918.png


So I guess we'll upgrade 🙂



View solution in original post

0 Karma

mpasini
Engager

Actually,  I found that the "wrapping" option was lost until the version 8.0.4 when the "Wrap Results" button was added:

mpasini_0-1628521423918.png


So I guess we'll upgrade 🙂



View solution in original post

0 Karma

richgalloway
SplunkTrust
SplunkTrust

If seems like you've already found the answer - change index.jsx as you prefer.  However, it's possible that fix is already present in one of the 18 Splunk versions released since 8.0.1 so you may want to consider a newer release.  You also can ask for the change at https://ideas.splunk.com

---
If this reply helps you, an upvote would be appreciated.
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!