Splunk Search

Sourcetype count per host

warmup031
Explorer

Hello,

I would like to Check for each host, its sourcetype and count by Sourcetype.
I tried host=* | stats count by host, sourcetype

But in fact I need all the sourcetypes to be set as column, and get the count by host for each sourcetype. Can you help ?

Many thanks

Labels (1)
Tags (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @warmup031,
did you tried?

index=your_index 
| stats count by sourcetype host

host=* isn't needed because all the events has the field host and use always the index in main search.

Ciao.
Giuseppe

View solution in original post

0 Karma

warmup031
Explorer

Hello gcusello and adonio, I already tried thèse search but my main problem is to set each sourcetype as a column, hosts as row and get sourcetype count valid for each host
Thank you

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @warmup031,
did you tried?

index=your_index 
| stats count by sourcetype host

host=* isn't needed because all the events has the field host and use always the index in main search.

Ciao.
Giuseppe

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @warmup031,
please, try this

index=wineventlog
| chart count OVER host BY sourcetype

Ciao.
Giuseppe

0 Karma

warmup031
Explorer

Wonderful, thank you very much Giuseppe

0 Karma

gcusello
SplunkTrust
SplunkTrust

You're welcome!
Ciao and Next time.
Giuseppe

0 Karma

adonio
Ultra Champion

try this:

| tstats count as event_count where index=* by host sourcetype

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...