Splunk Search

Show multiple machines for lockouts

Ewong
Explorer

Hi all,

A past consultant of ours wrote the following correlation search to detect excessive user account lockouts:

index=wineventlog EventCode=4740| stats count min(_time) as firstTime max(_time) as lastTime by user, signature | `ctime(firstTime)` | `ctime(lastTime)` | search count > 5

 

The results display the following:

usersignaturecountfirstTimelastTime
<user name>A user account was locked out<count>01/07/2021 07:57:1001/14/2021 02:56:51

 

The count above is a total of lockouts from different machines in our environment over a period of time.

 

How can I add an additional column to list the actual machine names causing the lockouts (this data would be taken from the particular field "dest_nt_domain") And is there a better way of doing this?

ie)

usersignaturecountfirstTimelastTimemachines
<user name>A user account was locked out<count>01/07/2021 07:57:1001/14/2021 02:56:51<computer1>, <computer2>, ...

 

Labels (2)
0 Karma
1 Solution

scelikok
SplunkTrust
SplunkTrust

Hi @Ewong,

Please try below;

index=wineventlog EventCode=4740 
| stats count min(_time) as firstTime max(_time) as lastTime values(dest_nt_domain) as machines by user, signature 
| `ctime(firstTime)` 
| `ctime(lastTime)` 
| search count > 5

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

Try this

index=wineventlog EventCode=4740| stats count min(_time) as firstTime max(_time) as lastTime, values(dest_nt_domain) as machines by user, signature | `ctime(firstTime)` | `ctime(lastTime)` | search count > 5
---
If this reply helps you, Karma would be appreciated.
0 Karma

Ewong
Explorer

That worked remarkably, thank you!

0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @Ewong,

Please try below;

index=wineventlog EventCode=4740 
| stats count min(_time) as firstTime max(_time) as lastTime values(dest_nt_domain) as machines by user, signature 
| `ctime(firstTime)` 
| `ctime(lastTime)` 
| search count > 5

 

If this reply helps you an upvote is appreciated.

If this reply helps you an upvote and "Accept as Solution" is appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...