Splunk Search

Search Chain

phillipmadm
Explorer

Hopefully this is an easy one.
We have an alert setup that notifies us if a specific error occurs more than 30 times in 1 minute. It works and gives us a nice little report of the hit count. Since this report is a mass disconnect alert, it was based on the quantity of termination messages. We now need to notify the users associated with the mass disconnect. Username field is available in the source messages but I'm having an issue chaining the logic together.

Base alert below.
index=security source="application.log" application_message=termination| bucket _time span=1m | stats count by _time | WHERE count > 30

Tags (1)
0 Karma
1 Solution

DalJeanis
Legend
index=security source="application.log" application_message=termination
| bucket _time span=1m 
| stats count as termCount, values(username) as username by _time 
| WHERE termCount > 30 

The result will be a multivalue field with each username in it.

If you wanted to break out the field again for individual notification, then use

| mvexpand username

View solution in original post

0 Karma

DalJeanis
Legend
index=security source="application.log" application_message=termination
| bucket _time span=1m 
| stats count as termCount, values(username) as username by _time 
| WHERE termCount > 30 

The result will be a multivalue field with each username in it.

If you wanted to break out the field again for individual notification, then use

| mvexpand username
0 Karma

phillipmadm
Explorer

Worked like a charm.
Thanks

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...