Splunk Search

Problems with search on chart

kailun92
Communicator

I saw this command and tried to imitate it
sourcetype="wind" | eval intscale="SCALE"+tostring(floor(scale/10)*10) | chart count over month by intscale | sort by month
alt text

What is wrong with my command ? Anybody can guide me ? I would like to show temperature(Y-axis) on monthly (X-axis).

sourcetype="CurrentWeatherSG" | chart count over hour by mean(current_temperature)

I only tried this sourcetype="CurrentWeatherSG" | chart max(current_temperature) as Max, min(current_temperature) as Min over _time but the _time is all ... ... ... I wanted to show the numbers on X-axis.

1 Solution

martin_mueller
SplunkTrust
SplunkTrust

Charting over time usually calls for a timechart, something like this:

... | timechart span=1mon max(current_temperature) as Max, min(current_temperature) as Min

View solution in original post

martin_mueller
SplunkTrust
SplunkTrust

Charting over time usually calls for a timechart, something like this:

... | timechart span=1mon max(current_temperature) as Max, min(current_temperature) as Min
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...