Splunk Search

How to separate string with regex?

m0rt1f4g0
Explorer

Hi!

I would like to separate the field Privilegio

 

|---------------------------|-------------------------------------------------------------------------------------------|-------------|
|   src_user                      |      Privilegio                                                                                                                     |   count      |
|---------------------------|-------------------------------------------------------------------------------------------|-------------|
|   user-RAC0308$      | SeSecurityPrivilege                                                                                                      |    8127     |
|                                          |                                          SeBackupPrivilege                                                               |                    |
|                                          |                                          SeRestorePrivilege                                                               |                    |
|                                          |                                          SeTakeOwnershipPrivilege                                               |                    |
|                                          |                                          SeDebugPrivilege                                                                  |                    |
|                                          |                                          SeSystemEnvironmentPrivilege                                      |                    |
|                                          |                                          SeLoadDriverPrivilege                                                         |                    |
|                                          |                                          SeImpersonatePrivilege                                                      |                    |
|                                          |                                          SeDelegateSessionUserImpersonatePrivilege          |                    |
|                                          |                                          SeEnableDelegationPrivilege                                            |                    |
|                                          |                                          SeCreateTokenPrivilege                                                      |                    |
|                                          |                                          SeAssignPrimaryTokenPrivilege                                      |                     |
|---------------------------|--------------------------------------------------------------------------------------------|--------------|

 

Since it only counts the first value and the others are put with a tab, they are the windows privileges of the EventID 4672,  my query is the following:

index=oswinsec EventCode=4672
| stats values(PrivilegeList) as Privilegio count by src_user

m0rt1f4g0_0-1668840333515.pngm0rt1f4g0_0-1668840333515.png

 

Labels (5)
Tags (2)
0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

Does this help?

index=oswinsec EventCode=4672
| stats count by src_user PrivilegeList
0 Karma

m0rt1f4g0
Explorer

@ITWhisperer Hi,

No, I think the field takes it as a single string

 

m0rt1f4g0_0-1668849973099.pngm0rt1f4g0_0-1668849973099.png

 

0 Karma

yuanliu
SplunkTrust
SplunkTrust

In that case, you need to split PrivilegeList first.

index=oswinsec EventCode=4672
| eval PrivilegeList = split(PrivilegeList, "
       ") ``` include the proper indentation characcter(s) ```
| eval SeSecurityPrivilege = mvindex(PrivilegeList, 1, mvcount(PrivilegeList))
``` the first line, SeSecurityPrivilege, is a mere header ```
| stats values(SeSecurityPrivilege) as Privilegio count by src_user

 

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

All Work and No Play? Not at .conf26! Unwind at These Evening Events

Between hands-on technical sessions, keynote reveals, and diving into live architectures, .conf26 is packed ...

Join the Hackathon at .conf26 and build a No-Code AI agent

Join us for the AI Agent Buildathon, an in-person, three-hour hands-on Hackathon where you’ll use Splunk Agent ...

Level Up Your Workflow: Mastering Splunk Cloud Management via Terraform

Tech Talk Recap   From Chaos to Control: Scaling Splunk Cloud with Infrastructure as Code Managing apps in ...