Splunk Search

How to remove field values

syed_star357
New Member

Hi,

I want to remove source and source type field value of

Unix:Service
Unix:Uptime
Unix:Version
package
ps

Please help me, how to remove the mentioned field.
Screenshot is attached![alt text][1]

Tags (1)
0 Karma
1 Solution

javiergn
Super Champion
index=linux* 
NOT (sourcetype = "Unix:Service" OR sourcetype = "Unix:Uptime" OR sourcetype = "Unix:Version" OR sourcetype = "package" OR sourcetype = "ps") 
NOT (source = "Unix:Service" OR source = "Unix:Uptime" OR source = "Unix:Version" OR source = "package" OR source = "ps")
| stats max(_time) .... REST OF QUERY HERE

Let me know if that's what you need

View solution in original post

0 Karma

richgalloway
SplunkTrust
SplunkTrust

If by "remove" you intend to delete the data from the Splunk index, then it can't be done. Data in Splunk cannot be modified.
On the other hand, you may be wanting to not show certain fields. That is done with the fields command.

... | field - Unix:Service Unix:Uptime Unix:Version package ps
---
If this reply helps you, Karma would be appreciated.

javiergn
Super Champion
index=linux* 
NOT (sourcetype = "Unix:Service" OR sourcetype = "Unix:Uptime" OR sourcetype = "Unix:Version" OR sourcetype = "package" OR sourcetype = "ps") 
NOT (source = "Unix:Service" OR source = "Unix:Uptime" OR source = "Unix:Version" OR source = "package" OR source = "ps")
| stats max(_time) .... REST OF QUERY HERE

Let me know if that's what you need

0 Karma

syed_star357
New Member

Thanks, I got the answer for the same query.

0 Karma

sundareshr
Legend

Try this

index=linux* NOT (sourcetype=UNIX* OR source=UNIX*) | stats latest(_time) as last_time by host source sourcetype | ....
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...