Splunk Search

How to convert this SQL query to splunk search

benazir
Explorer

Hi ,
I have a sql query ,
Count distinct CHNL where MSG_NUM like 'cma%' group by MSG_TM.
Result should get display in hourly basis,

all the CHNL , MSG_NUM , MSG_TM is the column name , which has values . Kindly need your help to convert it .Result should be in hourly basis.

1 Solution

somesoni2
Revered Legend

Try something like,

index=foo sourceltype=bar MSG_NUM=cma* 
| bucket span=1h _time
| stats dc(CHNL) as uniq_channels by _time MSG_TM

or

index=foo sourceltype=bar MSG_NUM=cma* 
| timechart span=1h  dc(CHNL)  by MSG_TM

View solution in original post

somesoni2
Revered Legend

Try something like,

index=foo sourceltype=bar MSG_NUM=cma* 
| bucket span=1h _time
| stats dc(CHNL) as uniq_channels by _time MSG_TM

or

index=foo sourceltype=bar MSG_NUM=cma* 
| timechart span=1h  dc(CHNL)  by MSG_TM

benazir
Explorer

Thank you so much it works perfect with few modification.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Is your data already indexed or are you trying to read a SQL database from Splunk? If the former, see http://docs.splunk.com/Documentation/Splunk/6.5.2/SearchReference/SQLtoSplunk. If the latter, check out the Splunk DB Connect app.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...