Splunk Search

How do I match two fields from the same join command?

matthew_foos
Path Finder

Splunkers,

Search String:

admon-user-lookup-update

| eval src_user = (cn) 
| fields src_nt_domain, displayName, cn
| rename cn as user 
| join user 
    [ search index=winevents (EventCode=630 OR EventCode=4726 OR Eventcode=4720 OR EventCode=4725) dest_nt_domain="xxxx" 
    | fields user, action, ComputerName, EventCode, EventCodeDescription, src_user, status]

I am able to match "cn" with user to produce a display name correlation between userid and full name.. How can I match src_user to use display name as well?

0 Karma
1 Solution

felipesewaybric
Contributor

Unfortunately, the sub-search will run first, then the Splunk will run the main search. Try MAP.

View solution in original post

0 Karma

woodcock
Esteemed Legend

If you will show a minimal set of sample events and the desired result, I will answer your question. I do not at all understand the way that you have explained your problem but I am certain that it is solvable.

0 Karma

mstjohn_splunk
Splunk Employee
Splunk Employee

Hi @matthew.foos ,

Did the answer below solve your problem? If so, please resolve this post by approving it!

If your problem is still not solved, keep us updated so that someone else can help ya. Thanks for posting!

0 Karma

felipesewaybric
Contributor

Unfortunately, the sub-search will run first, then the Splunk will run the main search. Try MAP.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Make Your Machine Data AI-Ready in Splunk

Every team is getting ready for AI agents.   Thursday, November 12, 2026  |  11AM  PST / 2PM EST   ...

Splunk Asynchronous Forwarding Explained

Splunk asynchronous forwarding is often misunderstood as simply setting autoLBVolume. That is not quite right. ...

How to Monitor AI Agents with Splunk Agent Observability

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...