Splunk Search

How do I match two fields from the same join command?

matthew_foos
Path Finder

Splunkers,

Search String:

admon-user-lookup-update

| eval src_user = (cn) 
| fields src_nt_domain, displayName, cn
| rename cn as user 
| join user 
    [ search index=winevents (EventCode=630 OR EventCode=4726 OR Eventcode=4720 OR EventCode=4725) dest_nt_domain="xxxx" 
    | fields user, action, ComputerName, EventCode, EventCodeDescription, src_user, status]

I am able to match "cn" with user to produce a display name correlation between userid and full name.. How can I match src_user to use display name as well?

0 Karma
1 Solution

felipesewaybric
Contributor

Unfortunately, the sub-search will run first, then the Splunk will run the main search. Try MAP.

View solution in original post

0 Karma

woodcock
Esteemed Legend

If you will show a minimal set of sample events and the desired result, I will answer your question. I do not at all understand the way that you have explained your problem but I am certain that it is solvable.

0 Karma

mstjohn_splunk
Splunk Employee
Splunk Employee

Hi @matthew.foos ,

Did the answer below solve your problem? If so, please resolve this post by approving it!

If your problem is still not solved, keep us updated so that someone else can help ya. Thanks for posting!

0 Karma

felipesewaybric
Contributor

Unfortunately, the sub-search will run first, then the Splunk will run the main search. Try MAP.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Classic British Rock Bands

This puzzle series (first published here) is based on extracting information from statements about well-known ...

New to the Community? Join Us for an Exclusive Post .conf26 Welcome Session (Plus a ...

Keep the .conf26 Energy Going: Welcome to the Splunk Community! Whether we scanned your badge at the Community ...

Accelerate Splunk App Development with AI

  Learn how to automate the repetitive parts of your build cycle.   Register to Attend   Join our Tech Talk ...