Splunk Search

Fatal MetaData message re: sources.data in splunkd.log

Jaci
Splunk Employee
Splunk Employee

I'm getting this error in splunkd.log on Windows 7

What does this mean and how can it be corrected?

08-15-2010 05:18:01.854 FATAL MetaData - failed to rename D:\SPLUNK\var\lib\splunk\defaultdb\db\Sources.data.temp to D:\SPLUNK\var\lib\splunk\defaultdb\db\Sources.data: Access is denied.

There is no Sources.data.temp file in the directory

Tags (1)

Arseny
New Member

Experiencing the same issue on win2003 x64. However there is such file and permissions are ok. Any ideas? Search over the problematic index is very slow.

0 Karma

hexx
Splunk Employee
Splunk Employee

I suspect a permissions issue.

When you login as the user that splunkd runs as and you attempt to create a new file in D:\SPLUNK\var\lib\splunk\defaultdb\ , do you get an error or are you prompted for the need to be admin to make the change?

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...