Splunk Search

Event count mismatch when using using `field_name="*"` and `field_name!=""` in tstats query

jshah24
Explorer

Why is there a difference between the number of events scanned in both these queries?
Using below query getting statistics count 25 and number of events (Events label below search query) as 214.

| tstats values(XXXX.product_name) as "Product Name" from datamodel=XXXX where (XXXX.threat_name="*") by XXXX.threat_name

But, Using

| tstats values(XXXX.product_name) as "Product Name" from datamodel=XXXX where (XXXX.threat_name!="") by XXXX.threat_name

getting statistics count same 25 and number of events (Events label below search query) as 5,468.

DalJeanis
Legend

1) Are you running for a fixed time frame, such as earliest=-1d@d latest=@d?

2) Compare the output. Which threat_name are the events missing from?

0 Karma

jshah24
Explorer

Thanks for your response DalJeanis.
Yes, I am running queries for a fixed time frame.
I have updated the question as per my research. please see the updated question.

0 Karma

MuS
SplunkTrust
SplunkTrust

A few things to check here:

  • you are using summareisonly in the tstats search, are the DMA searches running and summaries are available?
  • compare apples with apples, use your base search from the data model with your get-_index search
  • talking of base search: does it return the expected results?
  • Knowledge objects available to the DMA searches?
  • permissions?

Just a starting point, but good to check ...

cheers, MuS

0 Karma

jshah24
Explorer

Thanks for the answer MuS.
I have updated the question as per my research and found the problem in this scenario.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...