Splunk Search

Drill Down Search

kjain041523
Observer

drilldown search in splunk notable is not capturing the original host which is mentioned in correlation search and generating 0 results how to resolve this issue.

 

Correlation Search:

index=wineventlog host IN (AZR01PSQL19CL01, AZR01PSQL19CL02)
(EventCode=1069 OR EventCode=1205 OR EventCode=1641 OR EventCode=1480)
| eval usecase=" SQL 2019 Cluster Failover"
| stats count min(_time) as firstTime max(_time) as lastTime by host EventCode Message
| eval severity=case (
EventCode=1205 OR EventCode=1480, "critical", EventCode=1069, "high", EventCode=1641, "medium"
)
| convert ctime(firstTime) ctime(lastTime)

Drilldown search
index=wineventlog host=$Host$
(EventCode=1069 OR EventCode=1205 OR EventCode=1641 OR EventCode=1480)
| eval usecase=" SQL 2019 Cluster Failover"
| stats count min(_time) as firstTime max(_time) as lastTime by host EventCode Message
| eval severity=case (
EventCode=1205 OR EventCode=1480, "critical", EventCode=1069, "high", EventCode=1641, "medium"
)
| convert ctime(firstTime) ctime(lastTime)

when checking the drilldown search from splunk notable, i'm not getting any results and showing below code
index=wineventlog host=aws01psplksh01
(EventCode=1069 OR EventCode=1205 OR EventCode=1641 OR EventCode=1480)
| eval usecase=" SQL 2019 Cluster Failover"
| stats count min(_time) as firstTime max(_time) as lastTime by host EventCode Message
| eval severity=case (
EventCode=1205 OR EventCode=1480, "critical", EventCode=1069, "high", EventCode=1641, "medium"
)
| convert ctime(firstTime) ctime(lastTime)


How to resolve this issue.
TIA

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @kjain041523 ,

you must use as token the same field name of the Detection search, in yur case $host$ and not $Host$.

Ciao.

Giuseppe

0 Karma

richgalloway
SplunkTrust
SplunkTrust

This probably should go in the Enterprise Security channel, but it looks like the drilldown search is using token $Host$, which doesn't exist.  Try $host$.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...