Splunk Search

Datamodel search permissions

mmoermans
Path Finder

The following search : | tstats summariesonly=t count from datamodel=Network_Traffic

Results in no results, even when giving the user permissions to all indexes. The only way to give results is to add the "User" role.
Why can't I give a custom role access to search this datamodel? The datamodel is global and so is the CIM app so I am confused why this doesn't work.

Tags (1)
0 Karma

koshyk
Super Champion

user role normally have around 16-17 capabilities attached to it.
My suggestion is you to create something like
- create new role my_user_role
- inherit all capabilities as per user at the start
- detach one by one from my_user_role
- See which is the least possible option to grant you that search (my assumption is search capability only, but not sure)

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...