Splunk Search

Data model

Hamza08
Observer

Hi, 

how can I rewrite the following search using tstats and datamodel Network_Traffic?

index=*pan* sourcetype="pan:threat" severity IN ("high", "critical")

so far I have tested the following:

| tstats count from datamodel=Network_Traffic by All_Traffic.src_ip

but given the fact that “severity” is not a field included in the datamodel but just in the index, how can I add the condition severity IN ("high", "critical")?

 

thank you!

Labels (2)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

The tstats command only works with indexed fields.  If the field is not indexed and is not in a data model (same thing, really), then it can't be used with tstats.

---
If this reply helps you, Karma would be appreciated.
0 Karma

Hamza08
Observer

So if a field is not “Cim compliant” doest that mean that it cannot be used in tstats?

0 Karma

richgalloway
SplunkTrust
SplunkTrust

CIM-compliance is different and has nothing to do with whether a field can be used in the tstats command.  CIM-compliance means a field has a name and value described in the CIM manual (https://docs.splunk.com/Documentation/CIM/5.3.2/User/Howtousethesereferencetables).

The only fields the can be used in tstats are those created at index-time or those in an accelerated datamodel.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Tuning Edge Processor in Hybrid Mode: What Limits Each Data Path

When you run Edge Processor in hybrid mode, alongside a Splunk heavy forwarder on the same host, two questions ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Request for Professional Development: Attending .conf26

Winning Over the Boss: Your Pass to .conf26 conf26 is going to be here before you know it. If don't already ...