Splunk Search

Calculating average by week?

vonsolo29
Explorer

how do Icalculate the average number of events for each week for this search

index=dcl EventCode=4740 | eval date=strftime(_time,"%Y-%m-%d") | timechart span=7d count
Labels (1)
Tags (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

If you want a simple average daily count over a week, try this untested query:

index=dcl EventCode=4740 | timechart span=7d count as Avg | eval Avg=round(Avg/7, 2) 
---
If this reply helps you, Karma would be appreciated.

JoshSaunders
Explorer

And is there a way to restrict the average for the first query to only Monday through Friday of the current week, but also only include days that have past (for example, if it's Thursday, show the daily average for Monday through Thursday)?

Tags (1)
0 Karma

JoshSaunders
Explorer

Thank you for this. How would you do that same thing, but for daily average for this month only?

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Self-Healing Pipeline Is Now Generally Available: AI-Powered CIM Compliance

Maintaining data integrity across security and analytics pipelines is an ongoing challenge. Data ...

[Puzzles] Solve, Learn, Repeat: Family Trees

This puzzle (first published here is based on finding grandparents and grandchildren (inspired by a question ...

Break the Build: Inside the KubeDoom Lounge at .conf26

    You step up to the machine. The pixelated corridors of a certain 1993 FPS load in front of you, EMP Pulse ...