Splunk Search

Calculating average by week?

vonsolo29
Explorer

how do Icalculate the average number of events for each week for this search

index=dcl EventCode=4740 | eval date=strftime(_time,"%Y-%m-%d") | timechart span=7d count
Labels (1)
Tags (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

If you want a simple average daily count over a week, try this untested query:

index=dcl EventCode=4740 | timechart span=7d count as Avg | eval Avg=round(Avg/7, 2) 
---
If this reply helps you, Karma would be appreciated.

JoshSaunders
Explorer

And is there a way to restrict the average for the first query to only Monday through Friday of the current week, but also only include days that have past (for example, if it's Thursday, show the daily average for Monday through Thursday)?

Tags (1)
0 Karma

JoshSaunders
Explorer

Thank you for this. How would you do that same thing, but for daily average for this month only?

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Technical Support Is Moving to Cisco Support Tools

Introduction Splunk technical support is transitioning to Cisco’s support environment. This change brings ...

Recap | Agentic Operations Start with Context: Build the Right Data Foundation

Agentic Operations Start with Context: Build the Right Data Foundation   By Courtney Wright, Product Marketing ...

Recap | Assisted, Augmented or Agentic? Choose Your Splunk Starting Point

Assisted, Augmented or Agentic? Choose Your Splunk Starting Point   By Courtney Wright, Product Marketing ...