Splunk Enterprise

what to do if Lookuptable is not showing data for Automatic Lookup??

Shridhar7Hitesh
Explorer

Hello Guys,

I created a Lookup table called products.csv under destination as "source" and now I want to create an Automatic Lookup using same Lookup table under "source" destination. But while I am trying to do that move i am not seeing my .csv file.
I am wondering why and what reasons for that?
alt text

Tags (1)
0 Karma

woodcock
Esteemed Legend

Your scope is wrong. Select All for App and Any for Owner then you should be able to locate it.

0 Karma

Shridhar7Hitesh
Explorer

Hi Woodcock,

Even if I do that, when I have to "Add New" Automatic lookup, i need to tell the destination app where to settle the lookup down, and Lookup table (from where to look from ). That is where the problem lies. While choosing options from Lookup Table, I am not able to see my already fed .csv file.
How to get the file there in the "Lookup Table option" drill down?

Thanks,
Hitesh Shridhar

0 Karma

woodcock
Esteemed Legend

All KOs must have overlapping scope to interact. The best way to do this is to make them both part of the same app. You can move it to another app or clone it, if you have an older release. Look at your "URL" string and notice that there is an "app" value as part of the path segment. When you are adding the automatic lookup, make sure that this string matches the string of the app that currently owns the table. Then it will appear as an option.

0 Karma

DalJeanis
SplunkTrust
SplunkTrust

You can "move" it to the appropriate scope.

0 Karma

Shridhar7Hitesh
Explorer

Tried, that option as well. Didn't work out quite much.. 🙂

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!