Splunk Enterprise

Query and Reporting

revanthammineni
Path Finder

Hi Everyone! I'm working on a report to find out the hosts that are not reporting logs. Since it's a huge data set, I'm using command metadata. This command is not allowing me to set up an alert based on time range values. Can anyone suggest me how to pass dynamic time values to the command metadata.

Below is my query.

|metadata type=hosts index=_internal splunk_server_group=* | fields host | join type=left host [|metadata index=os* type=hosts splunk_server_group=* ] | table host lastTime | eval reporting=case(isnull(lastTime), "no", 1=1, "yes") | eval time=strftime(lastTime,"%b %d %T %Y %Z")  |dedup host |where reporting="no"

Thanks in advance.

Labels (1)
Tags (3)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try using tstats.

| tstats values(host) as host where index=_internal splunk_server_group=* 
| fields host 
| join type=left host 
    [| tstats values(host) as host, latest(_time) as lastTime where index=windows splunk_server_group=* ] 
| table host lastTime 
| eval reporting=case(isnull(lastTime), "no", 1=1, "yes") 
| eval time=strftime(lastTime,"%b %d %T %Y %Z") 
| dedup host
| where reporting="no"
---
If this reply helps you, Karma would be appreciated.

revanthammineni
Path Finder

Thanks for the response.  I could see the lastTime provided by metadata is different to the last(_time) in tstats.

Giving me different results. Any idea, How we can get the metadata lastTime field using tstats?

Thanks.

0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

if I recall right, you must use use “All time” with metadata to get real results. 
r. Ismo

0 Karma

revanthammineni
Path Finder

Yes. But I'm trying to set up an alerts. Command metadata not allowing me to dynamically pass time values. Also, tstats is not giving me the correct lastTime. 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...